Mantıksal formüller belli şartlara göre farklı sonuçlar döndürmek için kullanılan işlevlerdir. Bir hücrenin metin veya rakam içeriğini belli şartlara göre değerlendirerek başka bir sonuca ulaşmak için kullanırız. Kullanım yerleri oldukça fazladır. İleri seviye uygulamalarda veri doğrulama ve koşullu biçimlendirme hatta isim tanımlama kısımlarında da kullanabilirsiniz. Hızlıca bir giriş yapalım bu formüller nedir, nasıl çalışırlar.aşağıdaki sekmede ilgili formülleri ve açıklamalarını bulabilirsiniz.

  • EĞER
  • VE
  • YADA
  • DEĞİL
  • DOĞRU, YANLIŞ

Eğer formülü bir şartı kontrol ettiğimiz formüldür. Aslında baktığımızda en çok kullandığımız formülde bu formüldür. İngilizce kullananlar için IF formülüdür. Nasıl yazılıyor:

=EĞER(mantıksal_sınama,doğruysa_değer,yanlışsa_değer)

Mantıksal sınama kısmına bir hücre adresi ve bu hücre değerinin hangi değerle nasıl kıyaslanacağını da girmeniz gerekir. Kıyas kısmında sabit bir değer olabileceği gibi başka bir hücrenin adresi ile bu hücre içeriğini de kullanabilirsiniz. Bu kıyaslamanın sonucuna göre eğer doğru ise "Doğruysa Değer" kısmında yer alan ifade, yanlış ise "Yanlışsa değer" kısmında yer alan ifade çalıştırılır ya da bu alanlara metin girildi ise hücre içinde o metin gösterilir.

Hemen bir kaç örnek yapalım. Elimizde aşağıdaki gibi bir ölçüm raporu olsun:

NoDeğerToleransÖlçümSonuç
125,000,2525,10
212,250,2012,32
315,720,3016,00
410,000,5011,00
56,520,156,45

Tabloyu kopyalayarak A1 hücresinden itibaren Excel'e yapıştırın lütfen.

Buradaki ölçüm sonucu tolerans içinde kalıyor ise TAMAM, değil ise HATALI ifadesini sonuç kısmına yazmamız gereksin. Bu durumda EĞER formülünü aşağıdaki şekilde yazabiliriz:

=EĞER(MUTLAK(D2-B2)<=C2;"TAMAM";"HATALI"

Formül ne yapıyor; Ölçülen değeri Olması gereken değerden çıkarıyor, elde edilen değerin negatif sayı olması ihtimaline karşı MUTLAK formülü ile pozitif sayı haline getiriliyor vetolerans değeri ile kontrol ediliyor. Eğer tolerans değerinden küçük ise formül "TAMAM" değerini döndürüyor, değil ise "HATALI" ifadesini. Ve hücre içerisinde karşılaştırma sonucuna göre bu iki değerden biri gösteriliyor. Aşağıda ilgili formülün sonucunu gösterdim.

Eğer formülü sonucu
Eğer formülü sonucu

Bu formülü iç içe yazarak daha karmaşık kontroller de yapabilirsiniz. Bir sonraki yazımda bu formül ile farklı uygulamalar yapmayı planlıyorum, o yüzden şimdilik anlatacaklarım bu kadar.

VE formülünün amacı birden birden fazla koşulun hepsinin de doğru değer döndürüp döndürmediğini kontrol etmek amacı ile kullanılan mantıksal bir formüldür.  Yazılışı:

=VE(mantıksal1,[mantıksal2],....)

Gördüğünüz gibi 2. mantıksal karşılaştırma isteğe bağlı. Ve sonrasında başka karşılaştırlamalar da ekleyebilirsiniz. VE formülün sonucunda DOĞRU veya YANLIŞ değerlerini döndürülür.  Basit bir örnek yapalım. Aşağıdaki tabloyu Excel'e A1 hücresinden başlayarak kopyalayın:

PUAN>50 VE <75
50
65
40
70
80

Şimdi B2 sütununa aşağıdaki formülü yazalım ve en alta kadar çoğaltalım.

=VE(B2>50;B2<75)

Sonucu aşağıdaki resimde gösterdim.

VE Formülü Örnek Sonucu
VE Formülü Örnek Sonucu

YADA formülü de VE formülü gibi birden fazla koşulu birlikte değerlendirmek için kullanılır. VE'den farklı DOĞRU döndürebilmesi için karşılaştırma yapılan değerlerden sadece birinin doğru olması yeterlidir. Yazılımı:

=YADA(mantıksal1, [mantıksal2],...)

şeklindedir. VE ile farkını göstermek için VE formülünde kullandığımız tablonun yanına yeni bir kolona aşağıdaki formülü girin ve aşağıya kadar çoğaltın:

=YADA(B2>50;B2<75)

Gördüğünüz gibi tüm değerler doğru oldu çünkü hepsi ya 50'den büyük ya da 75'ten küçük. Şartların bir tanesi doğru olduğu için formül tüm seçeneklerde doğru döndürdü. Aşağıdaki resimde sonucu sizlere gösterdim.

YADA Formülü Örnek Sonucu
YADA Formülü Örnek Sonucu

DEĞİL elde ettiğimiz mantıksal sınanmanın tersini elde etmek için kullanılır. Başka bir deyişle DOĞRU veya YANLIŞ döndüren bir formülün tam tersini elde etmeye yarar. Yazılışı:

=DEĞİL(mantıksal)

Mantıksal sınama DOĞRU değerini döndürüyor ise DEĞİL(DOĞRU) formülü YANLIŞ olacaktır. Aynı şekilde YANLIŞ döndürüyor ise DEĞİL(YANLIŞ) DOĞRU olacaktır. Örnek olarak yine VE formülü sekmesinde verdiğimiz tabloyu ve VE formülünü kullanalım. Ve aşağıdaki formülü yazarak son satıra kadar uzatalım:

=DEĞİL(VE(D2>50;D2<75))

Göreceğiniz gibi sonuç VE formülünün bulduğu değerlerin tam tersidir. Aşağıdaki resimde sonuçlarını gösterdim.

Tam olarak bir formül diyemeyeceğimiz iki ifadeye gelelim sıra. Programlamaya aşına olanların bildiği iki mantıksal değer olan DOĞRU ve YANLIŞ ifadeleri. Normalde DOĞRU ifadesi 1'i ve YANLIŞ ifadesi 0 değerini ifade eder. Zaten Excel'de bazı formülleri formül değerlendirme ile incelediğinizde ilk adımda DOĞRU olan bir ifadenin, rakamlar ile işlemlerinde 1 olarak ele alındığını da göreceksiniz. Hatta kendi yaptığım bazı videolarda da bu özelliği göstermiştim.

Bu iki ifade uyumluluk için Excel'e eklenmiş ifadelerdir. Genel olarak nerede kullanıyoruz derseniz çok sık olmamakla birlikte yazdığınız iç içe EĞER ifadelerinde hatanın nerede meydana geldiğini test edilmek amacı ile kullanılabilir. Şahsen bugüne kadar çok ihtiyaç duymadığım ifadelerdir.

Mantıksal ifadelerin güçlü tarafı iç, içe kullanılabilmeleridir. İç içe EĞER kullanarak karmaşık kontroller yapabilir, EĞER ifadesi içinde VE, YADA gibi diğer ifadeleri veya bu ifadeler içinde EĞER ifadesini kullanabilirsiniz. Elde ettiğiniz sonucun tersini bulmak için DEĞİL ifadesi ile bu ifadeleri birleştirebilirsiniz ve oldukça kamaşık ve ileri seviye uygulamalar yapabilirsiniz.

İlginizi Çekebilecek Diğer Yazılar

Leave a Reply