DüşeyAra işlevi ile birden fazla kıstasa göre arama yapmak için yeterli yapıya sahip değil. Ancak bunu aşmak için ek bir yardımcı sütun oluşturarak burada arama yapabiliriz. Siz yardımcı sütun kullanmak istemezseniz buraya tıklayarak daha farklı teknikleri kullanabilirsiniz.

1. Uygulama
a. Örnek Tablo ve Yardımcı Sütun Ekleme

Uygulamaya başlamadan önce daha önceden defalarca kullandığım tabloyu bir kez daha verelim:

MüşteriÜrünOca.16žub.16Mar.16Nis.16May.16Haz.16Tem.16A§u.16Eyl.16Eki.16Kas.16Ara.16
ABC MühendislikÜrün A101112131415161718192021
ABC MühendislikÜrün B151617181920212223242526
ABC MühendislikÜrün C202122232425262728293031
ABC MühendislikÜrün D252627282930313233343536
ABC MühendislikÜrün E303132333435363738394041
CDE MakSanÜrün A404142434445464748495051
CDE MakSanÜrün B454647484950515253545556
CDE MakSanÜrün C505152535455565758596061
CDE MakSanÜrün D555657585960616263646566
CDE MakSanÜrün E606162636465666768697071
3R TeknikÜrün A656667686970717273747576
3R TeknikÜrün B707172737475767778798081
3R TeknikÜrün C757677787980818283848586
3R TeknikÜrün D808182838485868788899091
3R TeknikÜrün E858687888990919293949596

Burada müşteri ve ürün türüne göre bir arama yapmak istediğimizi varsayalım. Ben Müşteri ve ürün sütunlarından sonra yeni bir sütun açacağım. Sonrasında buraya aşağıdaki formülü giriyorum:

=B3&C3

Bu iki hücrenin içeriğini birleştirerek bana tek bir değer veriyor. Ben burada 2 sütundaki veriyi birleştirdim ancak siz daha fazla sütundaki verileri birleştirebilirsiniz. Anlaşılabilmesi adına da sütuna kıstas sütunu diyeceğim.

b. Alt Tablonun Hazırlanması ve Veri Çekme

DüşeyAra formülünde ilk iki sütunu kullanamadığım için arama işlemini Arama kıstası sütunundan başlayarak yağacağım, yani D2:P17 aralığını kullanacağım.

Sayfanın B19:EC20 aralığına da aşağıdaki gibi bir tablo oluşturdum. Seçim esnasında kolaylık olsun diye bunlara Veri Doğrulama->Liste seçeneği ile liste tanımladım.

Şimdi formülü yazmaya başlayalım. Aradığım değerler B20 ve C20 hücrelerinde ve bunların birleşimini kullanacağım:

=$B$20&$C$20

Bu formül bana “ABCMühendislikÜrünD” değerini verecek.

Aradığım 2. Değer Tarih değeri. Bu da D20 hücresinde yer alıyor. Tarih değerleri arama yapacağım tablonun ilk satırında yer alıyor, D2:P2. Tarihin bu tablonun kaçıncı sütununda yer aldığını bulalım:

=KAÇINCI($D$20;$D$2:$P$2;0)

Şimdi bu formülleri bir DÜŞEYARA formülünde birleştirelim:

=DÜŞEYARA($B$20:$C$20;$D$2:$P$17;KAÇINCI($D$20;$D$2:$P$2;0);0)

Gördüğünüz gibi yukarıdaki resimde verdiğim değerler için formülün döndüreceği değer 27 olacaktır.

3. Sonuç

Daha önce bahsettiğim çok kıstaslı arama işlemlerine göre çok daha basit bir yöntem. Tabii ek bir yardımcı sütun olması bazı durumlarda kafa karıştırılabilir veya bir raporda gözükmesi istenmeyebilir. Eğer bu sütunun gözükmesi istenmiyor ise sütun gizlenebilir ancak bu durumda tablonuza ek veriler eklerseniz gizli olan bu sütundaki formülleri yeni eklenen verileri kapsayacak şekilde güncellemeyi unutmamalısınız. Yoksa formül aradığınız değeri döndürmeyecektir.

İlginizi Çekebilecek Diğer Yazılar
Etiketler: , ,

Leave a Reply